can’t install/unpublish npm package version 0.0.1

can’t install/unpublish npm package version 0.0.1

Problem

I’ve got the strange 0.0.1 version in my package, and now I can’t install it…

$ npm install nodejs
npm http GET https://registry.npmjs.org/nodejs
npm http 304 https://registry.npmjs.org/nodejs
npm WARN engine nodejs@0.0.1: wanted: {"node":"~0.6.6"} (current: {"node":"v0.8.15","npm":"1.1.66"})
nodejs@0.0.1 node_modules/nodejs

Also, I can’t unpublish it:

$ npm unpublish --force nodejs@0.0.1
npm http GET https://registry.npmjs.org/nodejs
npm http 304 https://registry.npmjs.org/nodejs
npm http DELETE https://registry.npmjs.org/nodejs/-rev/3-9656e170167cee5a40e53aa02ac52080
npm http 500 https://registry.npmjs.org/nodejs/-rev/3-9656e170167cee5a40e53aa02ac52080
npm http DELETE https://registry.npmjs.org/nodejs/-rev/3-9656e170167cee5a40e53aa02ac52080
npm http 500 https://registry.npmjs.org/nodejs/-rev/3-9656e170167cee5a40e53aa02ac52080
npm http DELETE https://registry.npmjs.org/nodejs/-rev/3-9656e170167cee5a40e53aa02ac52080
npm http 500 https://registry.npmjs.org/nodejs/-rev/3-9656e170167cee5a40e53aa02ac52080
npm ERR! Error: case_clause {[]}: nodejs/-rev/3-9656e170167cee5a40e53aa02ac52080
npm ERR!     at RegClient.<anonymous> (/usr/local/Cellar/node/0.8.15/lib/node_modules/npm/node_modules/npm-registry-client/lib/request.js:259:14)
Problem courtesy of: Quadroid

Solution

Try running

npm cache clean

That particular version of nodejs is probably now in your cache. Take a look at ~/.npm and look at the package.json file in the nodejs directory before running the command. I suspect it will say 0.0.1.

Solution courtesy of: Ryan O’Neill

Discussion

Leave a Reply

Your email address will not be published. Required fields are marked *