Bundler 2.0 发布,RubyGems 依赖关系管理工具

Bundler 2.0 发布了,Bundler 是一种 Ruby 环境工具,它通过跟踪和安装所需的确切 RubyGems 和版本,为 Ruby 项目提供一致的环境。RubyGems(简称 gems)类似于 Linux 下的 atp-get,是一个用于对 Ruby 组件进行打包的系统。


此版本主要带来了一些小的变化,同时删除了一些生命周期已经结束的 Ruby 和 RubyGems 版本的官方支持:

  • 不再支持版本小于 2.3 的 Ruby。

  • 不再支持版本小于 3.0.0 的 RubyGems,RubyGems 3.0 中引入的 RubyGems 特定功能可以做到更好的在版本中自动切换。

  • 更改了 github:'some/repo' gems 源,默认使用 https 协议。

  • Errors/warnings 现在将输出到 STDERR。

  • 现在基于 Lockfile 在 Bundler 1 和 2 之间自动切换,这意味着可以同时安装 Bundler 1.17.3 和 Bundler 2.0.0。

详情查看发布公告

安装:

$ gem update --system

$ gem install bundler

更新:

$ bundle update --bundler

Leave a Reply

Your email address will not be published. Required fields are marked *